我用20种编程语言送上新年的祝福,"Happy new year!"

        又到了新的一年了,还有剩下最后的两天了,最近发生了好多的事,当然最主要的事就是考试了!不多过几天就是寒假了,心中多有感慨。感觉真的什么也没有学到!

        我是在大概初一的时候接触编程语言的,最初接触的是易语言,当初比较喜欢打游戏,也常常通宵,在穿越火线的时候经常开外挂。到后来几乎每个游戏都开外挂,一开外挂就是三年吧(当然不是每次都开,那么铺盖),在使用外挂之中我对外挂之制作充满了兴趣,不过至今10年后的我制作不出任何一款游戏的外挂,今后也不准备在这样方面做研究。

        我的感慨是的我第一次接触编程语言竟然距离我写出第一个代码想距离了8年,上了大学之后学校开设C语言经过半个月的努力我写出了Hello world!(由于我的脑子比较笨吧),这是我才知道什么是编程!在高中的时候我的数学学的还不错,对算法这块感觉她很有兴趣。我听了C语言程序设计老师讲授,渐渐想起来了我在初一接触编程语言的事,我在网吧下载易语言5.11在写了第一个窗口程序,写了一个按钮,单击按钮,弹出来一个信息框,我才发现这个这么的神奇。

        经过大一上学期半年的学习,我的C语言学的还可以,是因为遇到的题目几乎都是数学的算术题一样,但是我每次看到的都是白字黑框框的控制台程序,我几乎有半年时间都认为C语言只可以开发出来控制台程序,因为我见到的易语言开头就是Windows桌面应用程序,现在发现自己的认识是在好笑,但是我至今用所学的C/C++仍然写不出来一个Windows窗口的应用程序。我记得在学堂在线之中郑丽老师开头的一节课,在网上收集整理为大家用20中编程语言送上新年的祝福。新的一年学业有成,工作顺利。

C

#include <stdio.h>

int main()
{
   printf("Happy new year!");
   return 0;
}

 

C++

#include <iostream>
using namespace std;

int main()
{
   cout << "Happy new year!";
   return 0;
}

java

public class HappyNewYear {
    public static void main(String []args) {
       System.out.println("Happy new year!");
    }
}

Kotlin 

package Happy                 
 
fun main(args: Array<String>) 
   println("Happy new year!")       
}

Pascal 

program Happy;
begin
  writeln ('Happy new year!')
end.

Lua 

print("Happy new year!")

Node.js 

console.log("Happy new year!");

Go 

package main

import "fmt"

func main() {
   fmt.Println("Happy new year!")
}

Swift 

var myString = "Happy new year!"

print(myString)

VB.NET 

Imports System
		
Public Module modmain
   Sub Main()
		Console.WriteLine ("Happy new year!")
   End Sub
End Module

Bash 

#!/bin/bash
echo 'Happy new year!'

Perl 

#!/usr/bin/perl
		
print "Happy new year!"

Objective C 

#import <Foundation/Foundation.h>
		
int main(int argc, const char * argv[]){
     NSLog(@"Happy new year!");
     return (0);
}

Scala

object file {
  def main(args:Array[String])
  {
    println("Happy new year!")
  }
		
}

C#

using System;
namespace HappynewyearApplication
{
   class happyneayear
   {
      static void Main(string[] args)
      {
         Console.WriteLine("Happy new year!");
         Console.ReadKey();
      }
   }
}

Ruby

#!/usr/bin/ruby
# -*- coding: UTF-8 -*-

puts "Happy new year!";

Python3

#!/usr/bin/python
print("Happy new year!");

Python

# -*- coding: UTF-8 -*-
print 'Happy new year!'

PHP

<?php
echo 'Happy new year!';
?>

易语言

.版本 2

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行

标准输出 (#标准输出设备, “Happy new year!”)
返回 (0)  ' 可以根据您的需要返回任意数值
相关推荐
.版本 2 .程序集 自动瞄准子程序 .程序集变量 人物位置, 整数型 .程序集变量 当前选中, 整数型 .子程序 自动瞄准 .参数 HOOK1, 整数型 .参数 HOOK2, 整数型 .参数 HOOK3, 整数型 .参数 HOOK4, 整数型 .参数 HOOK5, 整数型 .局部变量 i, 整数型 .局部变量 敌人坐标数据x, 双精度小数型 .局部变量 敌人坐标数据y, 双精度小数型 .局部变量 敌人坐标数据z, 双精度小数型 .局部变量 本人坐标数据x, 双精度小数型 .局部变量 本人坐标数据y, 双精度小数型 .局部变量 本人坐标数据z, 双精度小数型 .局部变量 D3D距离, 小数型 .局部变量 最近距离, 小数型 .局部变量 X角度, 双精度小数型 .局部变量 Y角度, 双精度小数型 .局部变量 人物地址, 整数型 .局部变量 人物一级, 整数型 .局部变量 敌人基址, 整数型 .局部变量 X差距, 双精度小数型 .局部变量 Y差距, 双精度小数型 .局部变量 Z差距, 双精度小数型 .局部变量 敌人阵营, 整数型 .局部变量 敌人视角, 小数型 .局部变量 临时位置, 整数型 .局部变量 敌人数量, 整数型 人物地址 = 汇编_读整数型 (#人物基址) .如果真 (人物地址 > 0) .如果真 (汇编_读整数型 (#本人死亡基址) = 1) 敌人数量 = 取显示人物数量 () .判断开始 (敌人数量 = 8) 人物一级 = 汇编_读整数型 (人物地址 + #坐标一级) 本人坐标数据x = 汇编_读小数型 (人物一级 + 224) 本人坐标数据z = 汇编_读小数型 (人物一级 + 228) 本人坐标数据y = 汇编_读小数型 (人物一级 + 232) 敌人阵营 = 1 - 汇编_读整数型 (#阵营基址) .如果真 (当前选中 < 8 且 汇编_读整数型 (#本人位置) < 8) 当前选中 = 255 .如果真结束 .如果真 (当前选中 > 7 且 汇编_读整数型 (#本人位置) > 7) 当前选中 = 255 .如果真结束 .如果真 (当前选中 = 255) 最近距离 = 0 临时位置 = 255 .计次循环首 (8, i) 人物位置 = i - 1 + 敌人阵营 × 8 敌人基址 = 汇编_读整数型 (#敌人基址 + 人物位置 × #坐标基址规律) .如果真 (汇编_读整数型 (敌人基址 + #是否死亡偏移) = 1) 敌人坐标数据x = 汇编_读小数型 (敌人基址 + #坐标X偏移) 敌人坐标数据z = 汇编_读小数型 (敌人基址 + #坐标Z偏移) 敌人坐标数据y = 汇编_读小数型 (敌人基址 + #坐标Y偏移) D3D距离 = 取3D坐标距离 (本人坐标数据x, 本人坐标数据y, 敌人坐标数据x, 敌人坐标数据y) .如果真 (最近距离 = 0) 最近距离 = D3D距离 临时位置 = 人物位置 .如果真结束 .如果 (D3D距离 < 最近距离) 最近距离 = D3D距离 临时位置 = 人物位置 .否则 .如果真 (i = 8) 临时位置 = 人物位置 .如果真结束 .如果结束 .如果真结束 .计次循环尾 () 当前选中 = 临时位置 .如果真结束 .判断 (敌人数量 = 16) 人物一级 = 汇编_读整数型 (人物地址 + #坐标一级) 本人坐标数据x = 汇编_读小数型 (人物一级 + 224) 本人坐标数据z = 汇编_读小数型 (人物一级 + 228) 本人坐标数据y = 汇编_读小数型 (人物一级 + 232) .如果真 (当前选中 = 255) 最近距离 = 0 临时位置 = 255 .计次循环首 (16, i) .如果 (汇编_读整数型 (#本人位置) ≠ i - 1) 人物位置 = i - 1 .否则 到循环尾 () .如果结束 敌人基址 = 汇编_读整数型 (#敌人基址 + 人物位置 × #坐标基址规律) .如果真 (汇编_读整数型 (敌人基址 + #是否死亡偏移) = 1) 敌人坐标数据x = 汇编_读小数型 (敌人基址 + #坐标X偏移) 敌人坐标数据z = 汇编_读小数型 (敌人基址 + #坐标Z偏移) 敌人坐标数据y = 汇编_读小数型 (敌人基址 + #坐标Y偏移) D3D距离 = 取3D坐标距离 (本人坐标数据x, 本人坐标数据y, 敌人坐标数据x, 敌人坐标数据y) .如果真 (最近距离 = 0) 最近距离 = D3D距离 临时位置 = 人物位置 .如果真结束 .如果 (D3D距离 < 最近距离) 最近距离 = D3D距离 临时位置 = 人物位置 .否则 .如果真 (i = 16) 临时位置 = 人物位置 .如果真结束 .如果结束 .如果真结束 .计次循环尾 () 当前选中 = 临时位置 .如果真结束 .判断 (敌人数量 = 15) 人物一级 = 汇编_读整数型 (人物地址 + #坐标一级) 本人坐标数据x = 汇编_读小数型 (人物一级 + 224) 本人坐标数据z = 汇编_读小数型 (人物一级 + 228) 本人坐标数据y = 汇编_读小数型 (人物一级 + 232) .如果真 (当前选中 = 255) 最近距离 = 0 临时位置 = 255 .计次循环首 (16, i) .如果 (汇编_读整数型 (#本人位置) ≠ i - 1) 人物位置 = i - 1 .否则 到循环尾 () .如果结束 敌人基址 = 汇编_读整数型 (#敌人基址 + 人物位置 × #坐标基址规律) .如果真 (汇编_读整数型 (敌人基址 + #是否死亡偏移) = 1) .如果真 (汇编_读整数型 (敌人基址 + #是否为生化) = 1) 敌人坐标数据x = 汇编_读小数型 (敌人基址 + #坐标X偏移) 敌人坐标数据z = 汇编_读小数型 (敌人基址 + #坐标Z偏移) 敌人坐标数据y = 汇编_读小数型 (敌人基址 + #坐标Y偏移) D3D距离 = 取3D坐标距离 (本人坐标数据x, 本人坐标数据y, 敌人坐标数据x, 敌人坐标数据y) .如果真 (最近距离 = 0) 最近距离 = D3D距离 临时位置 = 人物位置 .如果真结束 .如果 (D3D距离 < 最近距离) 最近距离 = D3D距离 临时位置 = 人物位置 .否则 .如果真 (i = 16) 临时位置 = 人物位置 .如果真结束 .如果结束 .如果真结束 .如果真结束 .计次循环尾 () 当前选中 = 临时位置 .如果真结束 .默认 .判断结束 敌人基址 = 汇编_读整数型 (#敌人基址 + 当前选中 × #坐标基址规律) .如果 (汇编_读整数型 (敌人基址 + #是否死亡偏移) = 1) 本人坐标数据x = 本人坐标数据x × -1 敌人坐标数据x = 汇编_读小数型 (敌人基址 + #坐标X偏移) 敌人坐标数据z = 汇编_读小数型 (敌人基址 + #坐标Z偏移) - 35 敌人坐标数据y = 汇编_读小数型 (敌人基址 + #坐标Y偏移) 敌人视角 = 取鼠标横角度 (敌人基址) .判断开始 (敌人视角 ≥ 0 且 敌人视角 < 91) 敌人坐标数据x = 敌人坐标数据x + 取绝对视角 (敌人视角) × 0.5111111111111 敌人坐标数据y = 敌人坐标数据y + 55 - 取绝对视角 (敌人视角) × 0.5111111111111 .判断 (敌人视角 > 90 且 敌人视角 < 181) 敌人坐标数据x = 敌人坐标数据x + 55 - 取绝对视角 (敌人视角) × 0.5111111111111 敌人坐标数据y = 敌人坐标数据y - 取绝对视角 (敌人视角) × 0.5111111111111 .判断 (敌人视角 > 180 且 敌人视角 < 271) 敌人坐标数据x = 敌人坐标数据x - 取绝对视角 (敌人视角) × 0.5111111111111 敌人坐标数据y = 敌人坐标数据y - (55 - 取绝对视角 (敌人视角) × 0.5111111111111) .判断 (敌人视角 > 270 且 敌人视角 < 361) 敌人坐标数据x = 敌人坐标数据x - (55 - 取绝对视角 (敌人视角) × 0.5111111111111) 敌人坐标数据y = 敌人坐标数据y + 取绝对视角 (敌人视角) × 0.5111111111111 .默认 .判断结束 敌人坐标数据x = 敌人坐标数据x × -1 X差距 = 本人坐标数据x - 敌人坐标数据x Y差距 = 本人坐标数据y - 敌人坐标数据y Z差距 = 本人坐标数据z - 敌人坐标数据z X角度 = 求X角度 (X差距, Y差距) Y角度 = 求Y角度 (X差距, Y差距, Z差距) .如果 (汇编_读整数型 (敌人基址 + #是否死亡偏移) = 1) 汇编_写小数型 (人物地址 + #鼠标Y偏移, Y角度 × 0.01745329300563) 汇编_写小数型 (人物地址 + #鼠标X偏移, X角度 × 0.01745329300563) .否则 .如果结束 .否则 当前选中 = 255 .如果结束 .如果真结束 .如果真结束 .子程序 切换选定人物 .局部变量 敌人基址, 整数型 .局部变量 i, 整数型 .局部变量 敌人坐标数据x, 小数型 .局部变量 敌人坐标数据y, 小数型 .局部变量 敌人坐标数据z, 小数型 .局部变量 本人坐标数据x, 小数型 .局部变量 本人坐标数据y, 小数型 .局部变量 本人坐标数据z, 小数型 .局部变量 D3D距离, 小数型 .局部变量 最近距离, 小数型 .局部变量 临时位置, 整数型 最近距离 = 0 临时位置 = 255 .计次循环首 (16, i) 敌人基址 = 汇编_读整数型 (#敌人基址 + (i - 1) × #坐标基址规律) .如果真 (汇编_读整数型 (敌人基址 + #是否死亡偏移) = 1) .如果真 (汇编_读整数型 (敌人基址 + 6128) = 1) 敌人坐标数据x = 汇编_读小数型 (敌人基址 + #坐标X偏移) 敌人坐标数据z = 汇编_读小数型 (敌人基址 + #坐标Z偏移) 敌人坐标数据y = 汇编_读小数型 (敌人基址 + #坐标Y偏移) D3D距离 = 取3D坐标距离 (本人坐标数据x, 本人坐标数据y, 敌人坐标数据x, 敌人坐标数据y) .如果真 (最近距离 = 0) 最近距离 = D3D距离 临时位置 = 人物位置 .如果真结束 .如果 (D3D距离 < 最近距离) 最近距离 = D3D距离 临时位置 = 人物位置 .否则 .如果真 (i = 16) 临时位置 = 人物位置 .如果真结束 .如果结束 .如果真结束 .如果真结束 .计次循环尾 () 当前选中 = 临时位置 .如果真 (当前选中 = 255) 当前选中 = 0 返回 () .如果真结束 .如果真 (当前选中 ≥ 15) 当前选中 = 0 返回 () .如果真结束 当前选中 = 当前选中 + 1 .子程序 取3D坐标距离, 小数型 .参数 本人x, 小数型 .参数 本人y, 小数型 .参数 敌人x, 小数型 .参数 敌人y, 小数型 .局部变量 距离, 双精度小数型 本人x = 本人x - 敌人x 本人y = 本人y - 敌人y 距离 = 求平方根 (本人x × 本人x + 本人y × 本人y) 返回 (距离) .子程序 取鼠标横角度, 小数型 .参数 基址, 整数型 .局部变量 鼠标横坐标, 双精度小数型 鼠标横坐标 = 汇编_读小数型 (基址 + 128) ÷ 0.01745329300563 .判断循环首 (鼠标横坐标 > 360) 鼠标横坐标 = 鼠标横坐标 - 360 .判断循环尾 () .判断循环首 (鼠标横坐标 < 0) 鼠标横坐标 = 鼠标横坐标 + 360 .判断循环尾 () 返回 (鼠标横坐标) .子程序 取绝对视角, 小数型 .参数 视角, 小数型 .判断循环首 (视角 > 100) 视角 = 视角 - 100 .判断循环尾 () 返回 (视角)
©️2020 CSDN 皮肤主题: 程序猿惹谁了 设计师:白松林 返回首页
实付 9.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值